[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: [RFC] Officially drop support for Windows '9X and NT 4.0 with Subversion 1.6

From: Bert Huijben <B.Huijben_at_competence.biz>
Date: Fri, 19 Sep 2008 09:19:56 +0200

> -----Original Message-----
> From: Norbert Unterberg [mailto:nunterberg_at_gmail.com]
> Sent: vrijdag 19 september 2008 8:31
> To: Ivan Zhakov
> Cc: Bert Huijben; dev_at_subversion.tigris.org
> Subject: Re: [RFC] Officially drop support for Windows '9X and NT 4.0
> with Subversion 1.6
>
> 2008/9/17 Ivan Zhakov <chemodax_at_gmail.com>:
> > On Wed, Sep 17, 2008 at 6:10 PM, Bert Huijben
> <B.Huijben_at_competence.biz> wrote:
> >>
> >> Why don't we document Subversion 1.6 to require at least Windows
> 2000?
> >>
> > I'm +1 to drop support for Window 9x and NT 4.0, but to keep
> > supporting Windows 2000.
> > My arguments:
> > - Windows 9x and NT 4.0 officially unsupported by Microsoft for more
> > than two years.
> > - Most Windows binaries packages and clients does not support
Windows
> > 9x and NT 4.0
>
> What compiler was used to build the windows version of Subversion?
> Because Visual Studio 2008 dropped support for Windows 9x and NT, too.
> VS2008 is no longer able to generate executables that run on WIndows
> 9x/NT.

        Hi,

The subversion project itself does not deliver binaries. The binaries on
the http://subversion.tigris.org/getting.html page are build by
individuals or separate projects (See the list at the bottom of that
page).

[Note: Isn't there an official maintainer of the tigris.org builds?]

The Windows project generator currently supports
* Visual C++ 6.0 (6.X)
* Visual C++ 2002 and 2003. (7.X)
* Visual C++ 2005 and 2008. (8.X/9.X)

There are users of mingw and cygwin using the make file generator, but I
don't know the details for these versions.

The 6.0 compiler and the 8.X/9.X line are supported very well.
(Frequently automatic testing)
The 7.X line does work (recently confirmed with AnkhSVN 1.0.4), but has
no active testing.

My best guess is the 7.X line will be dropped before the 6.0 version;
but certainly not today.

But what you probably asked:

The Tigris builds use 6.0 (The same as apache)
The Collabnet binaries used 6.0 for 1.5 but there were plans to move to
2008. (Not sure about the 1.5.2 status)
TortoiseSVN uses 2008.
And finally SharpSvn/AnkhSVN/SlikSVN uses 2005, but might move to 2008
with Subversion 1.6 or 1.7. (Tested with 2008)

        Bert

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-09-19 09:20:21 CEST

This is an archived mail posted to the Subversion Dev mailing list.