[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [RFC] [PATCH] Raise minimal required version of Neon to 0.27

From: John Szakmeister <john_at_szakmeister.net>
Date: Wed, 10 Sep 2008 05:01:29 -0400

On Mon, Sep 8, 2008 at 6:23 AM, Stefan Sperling <stsp_at_elego.de> wrote:
> On Sun, Sep 07, 2008 at 03:14:46PM -0700, Blair Zajac wrote:
>> There's really nothing to gain from doing so except for limiting the systems
>> that svn can install on. I don't see the point. You never know when somebody
>> has some ancient system that they want to install svn on. It just makes it more
>> work then for somebody to get it installed.
>
> +1
>
> It's nice when things still work on old boxes.
>
> I'd argue not removing existing support for third party software
> from Subversion unless:
>
> 1) It obviously becomes too much of a maintenance burden for some reason.
> 2) We need to upgrade the dependencies because old versions don't
> have required features.
or,
  3) If the library is known to cause corruption.

This was the case with APR some time back.

-John

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-09-10 11:01:44 CEST

This is an archived mail posted to the Subversion Dev mailing list.