[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: GCC required for CollabNet certified Solaris 1.5.0 client

From: Daniel Berlin <dberlin_at_dberlin.org>
Date: Sat, 19 Jul 2008 22:56:55 -0400

libgcc is simply a runtime library for GCC compiled binaries anyway,
it is not a requirement that GCC itself be installed.

On Fri, Jul 18, 2008 at 12:32 PM, J J <eggsgloriouseggs_at_gmail.com> wrote:
> $ /opt/CollabNet_Subversion/bin/svn --help
> ld.so.1: svn: fatal: libgcc_s.so.1: open failed: No such file or directory
> Killed
>
> Is there anyway the next CollabNet certified Solaris client binary (1.5.1)
> can be compiled to not require gcc during runtime? At our company gcc
> cannot be installed onto production Solaris servers for security reasons.
>
> The 1.4.4 client didn't have this requirement.
>
> Another requirement that didn't exist before is that the SMCiconv package be
> installed. I don't understand all of the dependencies, but from my
> perspective fewer would make it easier to do this upgrade. The gcc
> dependency is a show stopper though. Worst case I can just build my own,
> but I'd prefer to stay "certified". :-)
>
> Thanks,
> Justin
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-07-20 04:57:30 CEST

This is an archived mail posted to the Subversion Dev mailing list.