[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r30782 - in branches/kwallet/subversion: include libsvn_subr

From: Stefan Sperling <stsp_at_elego.de>
Date: Sat, 26 Apr 2008 12:25:49 +0200

On Sat, Apr 26, 2008 at 01:51:19AM +0200, Arfrever Frehtes Taifersar Arahesis wrote:
> 2008-04-25 23:03:17 Stefan Sperling napisaƂ(a):
> > Shouldn't this be "stored in Kwallet." ?
> >
> > > @@ -113,7 +89,7 @@ simple_password_set(apr_hash_t *creds,
> > > CREDENTIALS. PASSWORD_GET is used to obtain the password value.
> > > PASSTYPE identifies the type of the cached password. CREDENTIALS are
> > > allocated from POOL. */
> > > -static svn_error_t *
> > > +svn_error_t *
> > > simple_first_creds_helper(void **credentials,
> >
> > This function needs some sort of prefix since it's not static
> > anymore, doesn't it? Or are the rules for libsvn_subr different?
>
> I'm getting compilation failure when these functions are declared as static:

Sure, taking the 'static' away is not a problem. If a function is
needed in more than one file, it cannot be static.

But functions that aren't static should be called svn_.... something,
isn't it? So I think you need to rename them.

I'd suggest:

  svn_error_t *
  svn_simple_providers_first_creds_helper(void **credentials,
 
This matches what other files in libsvn_subr do for non-static
functions. Compare io.c, for example, all non-static functions
there start with "svn_io_".

> > > @@ -220,7 +196,7 @@ simple_first_creds_helper(void **credent
> > > a set of CREDENTIALS to the simple auth provider's username and
> > > password cache. PASSWORD_SET is used to store the password.
> > > PASSTYPE identifies the type of the cached password. Allocates from POOL. */
> > > -static svn_error_t *
> > > +svn_error_t *
> > > simple_save_creds_helper(svn_boolean_t *saved,
> >
> > Same here.

svn_simple_providers_save_creds_helper?

-- 
Stefan Sperling <stsp_at_elego.de>                    Software Monkey
 
German law requires the following banner :(
elego Software Solutions GmbH                            HRB 77719
Gustav-Meyer-Allee 25, Gebaeude 12        Tel:  +49 30 23 45 86 96 
13355 Berlin                              Fax:  +49 30 23 45 86 95
http://www.elego.de                               CEO: Olaf Wagner
 
Store password unencrypted (yes/no)? No

  • application/pgp-signature attachment: stored
Received on 2008-04-26 12:24:12 CEST

This is an archived mail posted to the Subversion Dev mailing list.