[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] svneditor.bat

From: David Glasser <glasser_at_davidglasser.net>
Date: Mon, 21 Apr 2008 10:29:31 -0700

On Mon, Apr 21, 2008 at 2:30 AM, Bert Huijben <bert_at_vmoo.com> wrote:
> > -----Original Message-----
> > From: Karl Fogel [mailto:kfogel_at_red-bean.com]
> > Sent: maandag 21 april 2008 8:38
> > To: Branko Čibej <brane_at_xbc.nu>
> > Cc: Mark Reibert; Daniel Shahaf; dev_at_subversion.tigris.org
> > Subject: Re: [PATCH] svneditor.bat
> >
> > Branko Čibej <brane_at_xbc.nu> writes:
> > >> Is it safe to assume python will be in %PATH% ?
> > >
> > > Pretty much as safe as assuming that automatic running of .py files
> > is
> > > configured.
> >
> > Well, golly. Then I have no idea whether this patch should be applied.
> > But since we haven't heard of this problem before, I think it's
> > reasonable to treat Daniel as the exception (sorry Daniel).
>
> I tested the SharpSvn build environment (which builds subversion directly from subversion) on several systems and found systems with .py mapped and other systems with python in the path. On some other system just running a .py file just opened notepad with the .py file. (Not a very friendly action of a build system just trying to configure subversion).
>
> (I fixed this by looking for python.exe with a testfile and if python.exe is not found try just running the .py file.)
>
>
> I don't think the build system should assume that .py is mapped in one place /and/ python.exe is in the path in another place; as a current installation of Activestate python does not map the .py extension for running.
> And one of the other python installations I tried does not add python.exe to the path (not sure which release this is).
>
>
> We should choose a single method; and we probably did by running python.exe from the other places.

Yeah, Karl, are you sure? I'd trust a Windows guy like Bert here...
and do be aware that this script is brand new in 1.5 (I added it to
test propedit-on-URLs, and I'll happily admit that when I added it I
had no idea what the right way to make it work on Windows was).

--dave

-- 
David Glasser | glasser@davidglasser.net | http://www.davidglasser.net/
Received on 2008-04-22 08:12:54 CEST

This is an archived mail posted to the Subversion Dev mailing list.