[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.5.0-alpha2 tarballs up for signing/testing

From: Barry Scott <barry_at_barrys-emacs.org>
Date: Wed, 5 Mar 2008 22:13:43 +0000

On Mar 3, 2008, at 15:46, Mark Phippard wrote:

> On Sun, Mar 2, 2008 at 1:56 PM, Barry Scott <barry_at_barrys-
> emacs.org> wrote:
>> I'm building on Mac OS X 10.4.11 using the deps tar ball. I get this
>> error:
>>
>> /bin/sh ../libtool --quiet --mode=compile gcc -DHAVE_CONFIG_H -no-
>> cpp-precomp -I/usr/include -I/Users/barry/BuildTemp/Darwin_emotion/
>> subversion-1.5.0-alpha2/apr-util/xml/expat/lib -I.. -g -O2 -c
>> ne_xml.c -o ne_xml.lo
>> ne_xml.c: In function 'ne_xml_parse':
>> ne_xml.c:550: error: parse error before 'NE_FMT_XML_SIZE'
>>
>> I have been building 1.5.0 from its branch and trunk every now and
>> again so guess this is a recent change.
>>
>> Did I do something wrong in the build?
>
> I remember having something similar because I had expat 2.0 installed
> on OSX. There was a fix made for this that was committed and I
> thought was in 1.5 branch.
>
> Perhaps our fix breaks Neon build or it needs something similar?
> Look at r29057

subversion-deps includes expat 1.95.2 that is included in the apr-
util not 2.0
and it was built.

Are you saying that after building the 1.95.2 in apr-util the neon
build uses
another expat from somewhere else on my Mac?

Barry

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-03-05 23:14:28 CET

This is an archived mail posted to the Subversion Dev mailing list.