[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: What versions of SWIG? [was: 1.5.0-alpha1 tarballs up for testing/signing]

From: Hyrum K. Wright <hyrum_wright_at_mail.utexas.edu>
Date: Wed, 27 Feb 2008 08:28:42 -0600

Joe Swatosh wrote:
> Hi Hyrum,
>
> On Tue, Feb 26, 2008 at 8:45 AM, Hyrum K. Wright
> <hyrum_wright_at_mail.utexas.edu> wrote:
>> Joe Swatosh wrote:
>>> On Sun, Feb 24, 2008 at 7:42 PM, Joe Swatosh <joe.swatosh_at_gmail.com> wrote:
>>>> On Sun, Feb 24, 2008 at 2:35 PM, Eric Gillespie <epg_at_pretzelnet.org> wrote:
>>>>> "Joe Swatosh" <joe.swatosh_at_gmail.com> writes:
>>>>>
>>>>>> I was watching that thread. kou's patch seemed to help you. I tried
>>>>> Not really: http://svn.haxx.se/dev/archive-2008-01/0712.shtml
>>>>>
>>>>> Despite what I suggested there, I don't think it's a problem with
>>>>> my Ruby installation. I can build the 1.4 binding fine, and was
>>>>> able to reproduce the trunk failure with Dapper's ruby.
>>>>>
>>>>>> 1.3.27 today
>>>>>> on trunk and it built for me (but there were some test failures).
>>>>>> Looks like I'll have
>>>>>> to try a bunch of builds.....
>>>>> Hyrum says the swig files in the alpha tar file are from
>>>>> swig 1.3.33.
>>>>>
>>>> Good to know. There was another thread about 1.3.33 too. I
>>>> know that I can't build with that version, so I may be able to
>>>> help after all.
>>>>
>>>> What versions of SWIG are we supporting?
>>>>
>>> What versions of SWIG should work with 1.5?
>> alpha1 was rolled with 1.3.33, but that apparently had problems. I'm
>> planning on using 1.3.31 for alpha2, and to continue using it until
>> bindings maintainers can confirm that 1.3.33 works correctly. I don't
>> think we should consider the swig version "frozen" until we reach RC stage.
>>
>
> I guess I wasn't looking for a "frozen" version, but wondering how
> much effort I should put into making the Ruby bindings tests pass for
> SWIG versions < 1.3.29?

SWIG 1.3.29 was released on Mar-21-2006, almost 2 years ago. I suspect
that most people who are building using swig (not those who use our
pre-generated files) have at least 1.3.29. I'm fine with removing
support for swig <1.3.29, but I'm not a bindings maintainer, and not
that qualified to make that decision.

What do others think about requiring swig >1.3.29?

-Hyrum

Received on 2008-02-27 15:29:00 CET

This is an archived mail posted to the Subversion Dev mailing list.