[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Bug report: NTLM proxy authentication credentials

From: Yann <yann_eads_at_yahoo.fr>
Date: Mon, 25 Feb 2008 18:59:25 +0100 (CET)

Hello,

As Stefan Küng explained me on the TSVN mailing-list, this report should be sent on the Subversion mailing-list. Here it is:

I try to contact an SVN server behind my corporate proxy which needs an NTLM authentication. The proxy is properly configured in Settings with IP address, port, username (using the domain\username format) and password. Using these credentials work from a web browser but Checkout from TSVN doesn't. The error message is the following:
PROPFIND request failed on '/'
PROPFIND of '/': Could not create SSL connection through proxy server: Could not authenticate to proxy server: could not parse challenge

Using a network capture, I could find what the problem is:
TSVN correctly replies to NTLM queries and challenges from the proxy but doesn't provide the appropriate credentials. It seems that the username and password provided in the Settings are ignored and the Windows session login credentials are used instead. Actually I am sure that the domain name is not the right one, I am not sure for the user name since it's the same for both the Windows login and the web proxy in my case.

From the wireshark capture:
- 1st CONNECT request
Calling workstation domain: my_windowslogin_domain (ok, guess it's normal)
Calling workstation name: my_machine
- Proxy reply
HTTP 407 Proxy Authentication Required
Domain: my_proxy_domain (which is different than my_windowslogin_domain)
- 2nd CONNECT request
Domain name: my_windowslogin_domain (should be my_proxy_domain)
User name: my_login_username (should be my_proxy_username)
- Proxy reply
HTTP 403 Forbidden

Reading the capture, it becomes obvious that the credentials specified in the Settings of TSVN are not used and the authentication then fails (the windows session domain is different than the web proxy domain in my case).

I'm using version 1.4.8 released on 2007.02.16.

Since I didn't subscribe to this list, could you please CC my e-mail when replying?

Thanks,
Yann

       
---------------------------------
 Ne gardez plus qu'une seule adresse mail ! Copiez vos mails vers Yahoo! Mail
Received on 2008-02-25 23:52:04 CET

This is an archived mail posted to the Subversion Dev mailing list.