[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Ruby bindings on trunk build failure

From: Eric Gillespie <epg_at_pretzelnet.org>
Date: Tue, 05 Feb 2008 12:41:31 -0800

Eric Gillespie <epg_at_pretzelnet.org> writes:

> "Kouhei Sutou" <kou_at_cozmixng.org> writes:
>
> > Hi,
> >
> > 2008/1/31, Eric Gillespie <epg_at_pretzelnet.org>:
> > > I have swig 1.3.27 and ruby 1.8.6.111. I can build ruby bindings
> > > form 1.4.x with these versions with no trouble. This is the
> > > first time I've tried on trunk, so this is probably not new.
> > > David Glasser said he tried to build the ruby bindings from trunk
> > > recently, and also failed, and also has never had trouble with 1.4.x.

So, I found http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=453166
which seems to be the same problem. And it seems to be a problem
with certain versions of swig, right? I have just confirmed that
I cannot build swig-rb in 1.4.x if I do the swig work myself.
The only reason I could build them before is that I was building
from a tar file, which had been generated with a better swig.

So, we need to make sure we use the right swig when rolling tar
files, that's all. And I guess someone already does that, since
1.4.x was fine :).

-- 
Eric Gillespie <*> epg_at_pretzelnet.org
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-02-05 21:41:49 CET

This is an archived mail posted to the Subversion Dev mailing list.