[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[PATCH] Misleading/incomplete building instructions provided by m4-macro SVN_DOWNLOAD_APRUTIL (file an issue?)

From: Daniel L. Rall <dlr_at_finemaltcoding.com>
Date: 2007-10-29 20:42:08 CET

[Adding PATCH prefix to Subject line for notice by Karl.]

On Mon, 29 Oct 2007, Nicolai, Johannes wrote:

> Here is the patch for it:
>
> Index: build/ac-macros/aprutil.m4
> ===================================================================
> --- build/ac-macros/aprutil.m4 (revision 27464)
> +++ build/ac-macros/aprutil.m4 (working copy)
> @@ -112,7 +112,8 @@
> echo " http://svn.apache.org/repos/asf/apr/apr-util/branches/0.9.x \\"
> echo " apr-util"
> echo ""
> - echo "Run that right here in the top level of the Subversion tree,"
> + echo "Run that right here in the top level of the Subversion tree."
> + echo "Afterwards, run apr-util/buildconf in the same directory and"
> echo "then run configure again."
> echo ""
> AC_MSG_ERROR([no suitable APRUTIL found])
> Index: build/ac-macros/apr.m4
> ===================================================================
> --- build/ac-macros/apr.m4 (revision 27464)
> +++ build/ac-macros/apr.m4 (working copy)
> @@ -115,6 +115,7 @@
> echo " apr"
> echo ""
> echo "Run that right here in the top level of the Subversion tree."
> + echo "Afterwards, run apr/buildconf in the same directory and"
> echo "then run configure again."
> echo ""
> echo "Whichever of the above you do, you probably need to do"
>
>
> Regards
>
> Johannes
>
> -----Original Message-----
> From: Karl Fogel [mailto:kfogel@red-bean.com]
> Sent: Mon 10/29/2007 12:00 AM
> To: Nicolai, Johannes
> Cc: dev@subversion.tigris.org
> Subject: Re: Misleading/incomplete building instructions provided by m4-macro SVN_DOWNLOAD_APRUTIL (file an issue?)
>
> "Nicolai, Johannes" <Johannes.Nicolai@student.hpi.uni-potsdam.de> writes:
> > If you checkout the source of subversion, generate your configure
> > script and run it without having libaprutil installed, configure will
> > exit after having executed the m4 macro SVN_DOWNLOAD_APRUTIL in
> > ac-macros/apr-util.m4
> >
> > The text, this m4 macro outputs suggests to directly checkout the
> > aprutil source code (command is provided) and run configure again. If
> > you run configure again, it will run into an error because there is no
> > configure script (yet) for aprutils. You first have to run buildconf
> > in the checked-out directory apr-util before (that is not mentioned in
> > th m4 macro and might confuse people).
>
> Thank you for the concise description of the problem.
>
> > Question #1: Is this worth a P5 issue?
> >
> > Question #2: May I provide a patch that changes the m4 macro in a way
> > it tells you about the buildconf command or should I modify a m4 macro
> > so that it automatically calls buildconf before it tries to execute
> > configure?
>
> Yes, please! I think if we have the patch from you, then we don't
> need to bother to file an issue about this...
>
> > Question #3: The same problem occurs for libapr as well. Should I file
> > another issue for this?
>
> ...and same here :-).
>
> Best,
> -Karl
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: dev-help@subversion.tigris.org

-- 
Daniel Rall

  • application/pgp-signature attachment: stored
Received on Mon Oct 29 20:43:14 2007

This is an archived mail posted to the Subversion Dev mailing list.