[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

svn:ignore bug on Vista

From: David Krmpotic <david.krmpotic_at_gmail.com>
Date: 2007-10-07 12:19:02 CEST

Hi,

I noticed a pretty serious issue with SVN client. I'm 100% sure that the
behaviour I am experiencing on Vista is not normal. I'm using 1.4.5 and
didn't have the same problems on XP or Ubuntu.

D:\project>svn ps svn:ignore "*" log
property 'svn:ignore' set on 'app'
property 'svn:ignore' set on 'components'
property 'svn:ignore' set on 'config'
property 'svn:ignore' set on 'db'
property 'svn:ignore' set on 'doc'
property 'svn:ignore' set on 'lib'
property 'svn:ignore' set on 'log'
property 'svn:ignore' set on 'public'
svn: Cannot set 'svn:ignore' on a file ('Rakefile')

Svn is setting ignore on all(?) folders.. and it really is (I checked
dir-props-base for listed folders).

If I try to do that:

D:\project>cd log
D:\project\log>svn ps svn:ignore "*" .
property 'svn:ignore' set on '.'

log\.svn\dir-prop-base looks like this:

K 10
svn:ignore
V 5
.svn

END

So even this doesn't work... I was expecting a "*" instead of ".svn". As
a matter of fact in first attemp when it was setting svn:ignore all over
the place, in every dir-prop-base I noticed ".svn" as well...

It seems there are two problems at once.

I hope someone can confirm this. Thank you very much!

David

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sun Oct 7 12:20:09 2007

This is an archived mail posted to the Subversion Dev mailing list.