[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Buildbot failure not reported

From: Paul Burba <pburba_at_collab.net>
Date: 2007-06-18 17:25:37 CEST

> -----Original Message-----
> From: Kamesh Jayachandran
> Sent: Monday, June 18, 2007 11:06 AM
> To: Paul Burba
> Cc: dev@subversion.tigris.org; D.J. Heap; Lieven Govaerts
> Subject: Re: Buildbot failure not reported
>
> Paul,
> I have fixed the failure via r25431.

Kamesh,

I saw that, the test still fails on Win32 though. And the builbot
report I linked to was for r25439 (after your fix) and it reported the
tests as passing despite the failure clearly occurring in the log.

Just check out this and you'll see what I mean:

http://www.mobsol.be/buildbot/win32-xp%20VS2005/builds/1779/step-Test%20
fsfs%2Bra_local/0

I also just noticed that another test is failing:

FAIL: lock_tests.py 4: commit a locked file with a prop change

Paul
 
> With regards
> Kamesh Jayachandran
> Paul Burba wrote:
> > Due to a problem with merge_test-52 (mergeinfo can have empty rev
> > ranges the test) the test is failing spuriously. I'm
> working on fix
> > for that, but did notice that the VS2005 build bot is reporting
> > everything is passing even though the test fails,
> >
> http://www.mobsol.be/buildbot/win32-xp%20VS2005/builds/1779/step-Test%
> > 20
> > fsfs%2Bra_local/0
> >
> > ...
> > Testing Release configuration on local repository.
> > ...
> > Running all tests in merge_tests.py [33/50]...success ...
> > CMD: svn.exe "pl" "-vR"
> > "svn-test-work\working_copies\merge_tests-52.H\omega" "--config-dir"
> >
> "M:\svn-auto-test\fsfs\subversion\tests\cmdline\svn-test-work\local_tm
> > p\
> > config" <TIME = 1.062000>
> >
> > EXPECTED STDOUT:
> >
> > Properties on 'svn-test-work\working_copies\merge_tests-52.H\omega':
> >
> > prop:name : propval
> >
> > svn:mergeinfo : /A_COPY/B/E/beta:5
> >
> > /A_COPY/D/H/omega:3-4
> >
> > ACTUAL STDOUT:
> >
> > Properties on 'svn-test-work\working_copies\merge_tests-52.H\omega':
> >
> > prop:name : propval
> >
> > svn:mergeinfo : /A_COPY/B/E/beta:5
> >
> >
> > /A_COPY/D/H/omega:3-4
> >
> > EXCEPTION: SVNLineUnequal
> >
> > FAIL: merge_tests.py 52: mergeinfo can have empty rev
> ranges <snip>
> > ...
> >
> > Anyone know what wrong here?
> >
> > Paul
> >
> >
> >
> >> -----Original Message-----
> >> From: buildbot@mobsol.be [mailto:buildbot@mobsol.be]
> >> Sent: Monday, June 18, 2007 12:46 AM
> >> To: svn-breakage@subversion.tigris.org
> >> Subject: svn trunk r25439: PASS (win32-xp VS2005)
> >>
> >> Full details are available at:
> >> http://www.mobsol.be/buildbot/win32-xp%2520VS2005/builds/1779
> >>
> >> Author list: bhuvan
> >>
> >> Build Slave: djh-xp-vse2005
> >>
> >>
> >> Subversion Buildbot
> >> http://www.mobsol.be/buildbot/
> >>
> >>
> >> Last 100 lines of the build log (step: Cleanup ):
> >>
> >> Setting environment for using Microsoft Visual Studio
> 2005 x86 tools.
> >> Deleted file -
> >> C:\svn-builder\djh-xp-vse2005\build\subversion_vcnet.sln
> >>
> >>
> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail:
> >> svn-breakage-unsubscribe@subversion.tigris.org
> >> For additional commands, e-mail:
> >> svn-breakage-help@subversion.tigris.org
> >>
> >>
> >>
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
> > For additional commands, e-mail: dev-help@subversion.tigris.org
> >
> >
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Jun 18 17:26:35 2007

This is an archived mail posted to the Subversion Dev mailing list.