On Fri, 01 Jun 2007, Joe Swatosh wrote:
> On 6/1/07, Kouhei Sutou <email@example.com> wrote:
> >> Do we really want aliases here? Wouldn't changing the API names be
> >> sufficient?
> >Does it mean we only need mergeinfo and merge_info is
For a direct mapping to the Subversion core APIs, yes.
> > If it's true, I can't agree with you. merge_info
> >is more Rubyish name rather than mergeinfo because many Ruby
> >scripts use '_' between words. Rubyist will use merge_info
> >not mergeinfo. mergeinfo exists just only for respecting
> >original Subversion API.
> My feelings aren't that strong either way. I added the aliases
> because there was already a similar alias in the client. However, I
> think kou brings up a good point about the expectations of Ruby
It's the same in Java and C and Python and pretty much every language
(thus the original split between "mergeinfo" and "merge info"). I
don't have a strong preference here, but in the core C API, we wanted
to pick one and go with it, and the one chosen was "mergeinfo", to
help illuminate the fact that it's a single term, and not verb_noun,
which in some API names turned out to be quite confusing.
Received on Mon Jun 4 19:09:22 2007
- application/pgp-signature attachment: stored