[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Fix for issue #1789

From: Hyrum K. Wright <hyrum_wright_at_mail.utexas.edu>
Date: 2007-04-03 20:37:01 CEST

Jonathan Gilbert wrote:
> At 12:23 AM 2/19/2007 -0600, I wrote:
>> At 09:13 AM 2/19/2007 +0300, Ivan Zhakov wrote:
>>> I had the same problem. My problem was that Visual Studio cannot find
> Python.
>>> Try add path to Python binary directory at Visual Studio binary
>>> directories list.
>> Huh? That's confusing to me, as I didn't see Visual Studio trying to run
>> any python scripts during the build process. However, I'll give it a try;
>> hopefully it'll clear everything up for me as well :-)
>
> Well, this fixed my build problem, and I can confirm that the bug described
> by Subversion issue #1789 is plugged nicely by the latest revision of my
> patch to APR. I verified that the diff output (nearly 70 KB -- by
> coincidence, the same size as the random test case I threw together before
> I knew what the problem was) was complete & correct by applying it with
> "patch.exe" to a copy of the text-base and checking that I did in fact get
> the identical modifications originally made to the file.
>
> If the patch is accepted by the APR team, perhaps it could be part of the
> next release of Subversion :-)

Jonathan,
Do you have an update on whether or not your patch has been committed
into APR? If so, does is solve the problem in issue 1789?

-Hyrum

Received on Tue Apr 3 20:37:29 2007

This is an archived mail posted to the Subversion Dev mailing list.