[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: r21207 (Renaming --no-svndiff1 to --pre-1.4-compatible)

From: Max Bowsher <maxb1_at_ukf.net>
Date: 2006-08-24 14:27:48 CEST

Justin Erenkrantz wrote:
> My issue is that you feel the conversation was ended and I don't think
> that had happened yet. We knew that Brane wasn't happy with it, he
> never had an opportunity to reply to your 'logically countered' reply,
> and we just went ahead and merged it in r21223.

I don't feel that the conversation has ended, and Brane still has an
opportunity reply.

I went ahead and merged it because I think it's better that we have an
rc5 that we _might_ accept, than no rc at all whilst this conversation
continues.

> In general, if someone has an issue with a commit, we owe it to
> ourselves to let the conversation conclude with a consensus rather
> than just declaring that you win and attempting to stifle any further
> conversation.

Let rc5 be tossed *if* the conversation concludes with a consensus in
that direction. Either way, we'll have had the benefit of additional
soak time for the fixes merged since rc4. If the final consensus is that
we can release 1.4.0 rc5 as final, then we will have saved time.

> On this particular point, I resonate more with Brane's comments

Could you let me know why you don't agree with my counter-comments then,
please?

> as I
> think the new option name isn't a good choice as it gives the wrong
> impression to our users: pre-1.4-compatible is *not* accurate in any
> sense of the word - it implies that the repository will work with 1.0,
> 1.1, 1.2, etc to a naive admin - that's clearly not the case.

It's not _clearly_ not the case.

A pre-1.4-compatible FSFS repository will work with all versions before
1.4 except 1.0 in which FSFS wasn't supported at all.

A pre-1.4-compatible BDB repository will work with all versions before
1.4, except for the universal BDB caveat of keeping the same BDB version.

Could you clarify your objection, since to me, pre-1.4-compatible sounds
like a pretty accurate description.

> But,
> even more than that, we never had an opportunity to find a
> middle-ground that would be acceptable. Ugh. -- justin

Time's a little tight, to be sure, but the window is still open - 1.4.0
final isn't out yet.

Max.

Received on Thu Aug 24 14:28:40 2006

This is an archived mail posted to the Subversion Dev mailing list.