[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: corrupted FSFS repository

From: Thomas Beale <thomas_at_deepthought.com.au>
Date: 2006-02-02 17:06:52 CET

Thomas Beale wrote:
>
> Hi
>
> I have spent a few days looking for evidence and reports of this bug,
> which I posted on the users list. It appears to be known as issue
> 2467...http://subversion.tigris.org/issues/show_bug.cgi?id=2467
>
> Our experience of the problem is the same as reported in the issue.
>

I made an attempt to reproduce this as follows:

- removed revision 51 (the last & broken one) from the repository by hand
- recreated my workarea in such a way as to look (nearly) like it would
have prior to the commit that caused the broken revision
- did the same commit (can't guarantee the same byte for byte, but the
PDF file which returned the XML error was in fact unchanged).

This commit worked fine, and subsequent commits did as well. Good for us
in that the repo is working again, but bad in that I couldn't diagnose
anything - all I can say is that it discounts anything in the particular
PDF file. This would point more to a network problem, apache problem or
some other non content-related problem occurring during a commit.

If we get the error again, I will make further efforts to reproduce and
report it here.

- thomas beale

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Feb 2 17:17:44 2006

This is an archived mail posted to the Subversion Dev mailing list.