[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Re[2]: And more problems building 1.3.0-rc2: pre-generated *.swg files

From: David James <james82_at_gmail.com>
Date: 2005-11-08 19:12:49 CET

On 11/8/05, Lev Serebryakov <lev@serebryakov.spb.ru> wrote:
> Hello Justin,
>
> Tuesday, November 8, 2005, 5:19:49 AM, you wrote:
>
> JE> I believe when we tried the current versions of SWIG (1.3.27), the
> JE> bindings for Python and Perl were also broken. So, we have to stay at
> JE> 1.3.25 until they get their bugs fixed upstream. -- justin
> But proxies, generated by 1.3.25, are broken too! For gcc 2.95.x and MSVC6, and may be, other MSVC.

I've committed a workaround for this SWIG 1.3.25 bug in r17257, and
nominated this fix for 1.3.x. Lev, can you test my fix and see if it
helps with your problem?

> (2) Proxies for ruby can not be generated locally with newer swig.
Subversion only officially supports SWIG 1.3.25. SWIG 1.3.26 breaks
compatibility with older versions of SWIG, so we will have to modify
our code in order to support it.

Hope this helps,

David

--
David James -- http://www.cs.toronto.edu/~james
Received on Tue Nov 8 19:13:49 2005

This is an archived mail posted to the Subversion Dev mailing list.