[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Version compatibility of mod_*_svn to libsvn_*

From: Daniel Rall <dlr_at_finemaltcoding.com>
Date: 2005-10-04 20:06:25 CEST

On Tue, 04 Oct 2005, Marcus Rueckert wrote:

> On 2005-10-04 14:24:26 +0100, Max Bowsher wrote:
> > Is mod_{dav,authz}_svn:
> >
> > EITHER (a) a client of the subversion libraries like any other, hence a
> > mod_dav_svn should work with libsvn_* libraries of the same, _or any
> > greater_ 1.x version - e.g. 1.2.x mod_dav_svn with 1.3.x libsvn_* libs.
> >
> > OR (b) an integral part of the core subversion code, and thus should only
> > be used as part of a matched set of equal-versioned components.
>
> iirc it was b. there were some debian bug about it. and the team replied
> the API rules only applies to external APIS. not to the internal ones.

(a) sounds like way more trouble than it's worth.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Oct 4 20:05:48 2005

This is an archived mail posted to the Subversion Dev mailing list.