[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Hanging up of svn and apache process while using username argument with svn command.

From: Alexis Boutillier <alexis.boutillier_at_arteris.net>
Date: 2005-07-06 11:19:55 CEST

I found a reproductable hang in the using of username argument of svn
commands.

The problem can be reproduce in every part of the repository with an
1.2.0 client and a 1.1.2 client and with the svn update or svn commit
command (i didn't test other commands).

To create the hang i run :
"svn update --username=alexis" where the username is not the one with
which you was working on the working copy.
The command ask you for the password of the user and then hang.
When I kill the process, the working copy is left with every directory
locked.

I must kill the process to terminate the program on the server and
client side.

On the server side, the apache process doesn't end and keep using 100%
of the cpu.

I'm using :
db-4.3.28.NC
neon-0.24.7
apr-0.9.6
httpd-2.0.54
php-4.3.11
apr-util 0.9.6
subversion 1.2.0

I'm using an authentication file like this one :
[/]
*=rw
aTestUser=r

[/branches/dist1.2.2]
*=r
@distWriters=rw

[/trunk/tools/security]
*=
@distSecurity=rw

[/branches/dist1.2/tools/security]
*=
@security=rw

[/branches/dist1.2.2/tools/security]
*=
@distSecurity=rw

[groups]
security=alexis,aydon
distWriters=phi,aydon,noregress,calvin,jyp,alexis,boris,jmb,eric

I'm using ldap authentification system. I don't remember having those
problem with 1.1.2 server version but i'm not sure I use the username
argument in a command.

I have those error in the apache error log each time the process hang :
[Tue Jul 05 14:23:27 2005] [warn] [client 192.168.12.41] [23267]
auth_ldap authenticate: user alexis authentication failed; URI
/svn/trunk [ldap_simple_bind_s() to check user credentials
failed][Invalid credentials]
[Tue Jul 05 14:23:27 2005] [warn] [client 192.168.12.41] [23267]
auth_ldap authenticate: user alexis authentication failed; URI
/error/HTTP_UNAUTHORIZED.html.var [ldap_simple_bind_s() to check user
credentials failed][Invalid credentials]

Does any one could reproduce the problem ?

-- 
Boutillier Alexis
Methodology engineer
Arteris SA
The Network-on-Chip Company TM
www.arteris.net
6 par Ariane Immeuble Mercure
78284 Guyancourt Cedex
France
Office: (+33) 1 61 37 38 71
Fax:    (+33) 1 61 37 38 41
Alexis.Boutillier@arteris.net

attached mail follows:


I have a problem with subversion.

To reproduce the problem you have to issue on a working copy :
"svn update --username=alexis" where the username is not the one with
which you was working on the working copy.
The command ask you for the password of the user and then hang.
When I kill the process, the working copy is left with every directory
locked.

On the server side, the apache process doesn't end and keep using 100%
of the cpu.

I'm using :
db-4.3.28.NC
neon-0.24.7
apr-0.9.6
httpd-2.0.54
php-4.3.11
apr-util 0.9.6
subversion 1.2.0

I'm using an authentication file like this one :
[/]
*=rw
aTestUser=r

[/branches/dist1.2.2]
*=r
@distWriters=rw

[/trunk/tools/security]
*=
@distSecurity=rw

[/branches/dist1.2/tools/security]
*=
@security=rw

[/branches/dist1.2.2/tools/security]
*=
@distSecurity=rw

[groups]
security=alexis,aydon
distWriters=phi,aydon,noregress,calvin,jyp,alexis,boris,jmb,eric

The problem can be reproduce in the trunk or in the branch and with an
1.2.0 client and a 1.1.2 client.

I'm using ldap authentification system. I don't remember having those
problem with 1.1.2 server version but i'm not sure I use the username
argument in a command.

I have those error in the apache error log each time the process hang :
[Tue Jul 05 14:23:27 2005] [warn] [client 192.168.12.41] [23267]
auth_ldap authenticate: user alexis authentication failed; URI
/svn/trunk [ldap_simple_bind_s() to check user credentials
failed][Invalid credentials]
[Tue Jul 05 14:23:27 2005] [warn] [client 192.168.12.41] [23267]
auth_ldap authenticate: user alexis authentication failed; URI
/error/HTTP_UNAUTHORIZED.html.var [ldap_simple_bind_s() to check user
credentials failed][Invalid credentials]

I must kill the process to terminate the program on the server and
client side.

Does any one could reproduce the problem ?

-- 
Boutillier Alexis
Methodology engineer
Arteris SA
The Network-on-Chip Company TM
www.arteris.net
6 par Ariane Immeuble Mercure
78284 Guyancourt Cedex
France
Office: (+33) 1 61 37 38 71
Fax:    (+33) 1 61 37 38 41
Alexis.Boutillier@arteris.net
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Jul 6 11:28:29 2005

This is an archived mail posted to the Subversion Dev mailing list.