[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r11903 - trunk/subversion/bindings/java/javahl/src/org/tigris/subversion/javahl

From: Branko Čibej <brane_at_xbc.nu>
Date: 2004-11-15 00:15:27 CET

dlr@tigris.org wrote:

>Author: dlr
>Date: Sun Nov 14 16:48:41 2004
>New Revision: 11903
>
>Modified:
> trunk/subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/DirEntry.java
> trunk/subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/LogMessage.java
> trunk/subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/Revision.java
> trunk/subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/Status.java
>Log:
>A follow on to r10704 to eliminate some duplication of checks for
>valid revision numbers.
>
>
>* subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/LogMessage.java
> getRevision(): Leverage Revision.createNumber().
>
>
>* subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/DirEntry.java
> getRevision(): Leverage Revision.createNumber().
>
>
>* subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/Status.java
> getRevision(): Leverage Revision.createNumber().
>
>
>* subversion/bindings/java/javahl/src/org/tigris/subversion/javahl/Revision.java
> createNumber(long): Factory method which creates objects for valid
> revision numbers only (those greater than zero).
>
> getInstance(long), Revision.Number(long): Added @throws JavaDoc for
> the possible IllegalArgumentException.
>
>
Could we keep the log messages below 80 columns? In cases like this,
it's common to note the path prefix at the beginning of the log message
and use only relative paths later on; for example,

[in subversion/bindings/java/javahl/src/org/tigris/subversion/jsvshl]
* LogMessage.java (LogMessage.getRevision):
  

And so on. Note also that references to changed methods should include
the class name and be enclosed in parentheses, e.g.,
(LogMessage.getRevision) not getRevision(). I'd only use the full
signature when the name is ambiguous due to overloading. Same for
methods mentioned in the text of the log fragment.

-- Brane

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Nov 15 00:15:23 2004

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.