[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Fwd: mod_dav_svn over-escapes index tag?]

From: Peter N. Lundblad <peter_at_famlundblad.se>
Date: 2004-07-28 00:21:20 CEST

On Mon, 26 Jul 2004, Ben Collins-Sussman wrote:

> -----Forwarded Message-----
> From: Hiroharu Tamaru <tamaru@myn.rcast.u-tokyo.ac.jp>
> To: users@subversion.tigris.org
> Subject: mod_dav_svn over-escapes index tag?
> Date: Tue, 27 Jul 2004 05:00:43 +0900
>
> I run subversion 1.0.6 on mod_dav_svn/apache2/FreeBSD-stable.
>
> I needed the following patch to correctly view the headings
> (or whatever you would call it) of directory listings when
> viewing the repository with a web browser (Mozilla).
>
> It patches where the index tag such as
>
> <index rev="nn" path="/trunk/XXXX">
>
> is generated for an xml response. The strings that are
> failing are multibyte utf8 japanese characters that are in
> place of XXXXX above. It gets escaped and shows up on
> screen as-is, in %xx%xx%xx format.
>
Yes. A path is not an URL. I think it's a bug. Will apply the patch that
removes URI-escaping if no one objects. If we want an URL, we need to add
an href attribute.

Thanks for the patch, BTW.

Regards,
//Peter

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Jul 28 00:10:27 2004

This is an archived mail posted to the Subversion Dev mailing list.