[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: win32 build generator bizarreness

From: Max Bowsher <maxb_at_ukf.net>
Date: 2004-07-22 17:10:00 CEST

Branko ─Oibej wrote:
> Russell Yanofsky wrote:
>
>> Max Bowsher wrote:
>>
>>
>>> I've just stumbled on a curious fact.
>>>
>>> The ordering of user_deps in the win32 build generator changes from
>>> run to run.
>>>
>>> This is a little annoying when diffing 2 sets of build generator
>>> output which should be logically identical.
>>>
>>> Could some win32 build person have a think about this one?
>>>
>>>
>>
>> I've never noticed this, and I often look at build generator output. Can
you
>> give instructions to reproduce this?
>>
>>
> Nor have I. Did one of your latest patches perhaps break the ordering
> guarantees?

No, I went nowhere near anything that handles lists. Besides, I've also
reproduced it pre-r10381.

Regarding reproduction:

When running "./gen-make -t dsp", sometimes you will see spurious
"Wrote: build/win32/msvc-dsp/swig_java_java_msvc.dsp"
lines being output, even though nothing has changed to give cause for that
to be rewritten.

Unfortunately, I can't reproduce reliably.
In particular, if I run gen-make in a loop, it never seems to happen. I've
had best success reproducing when I re-run gen-make in a working copy that
I've left untouched for several hours.

Max.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Jul 22 17:10:57 2004

This is an archived mail posted to the Subversion Dev mailing list.