[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Handle "svn log" in working copy with empty repos

From: Michael W Thelen <thelenm_at_cs.utah.edu>
Date: 2004-06-30 21:12:21 CEST

* kfogel@collab.net <kfogel@collab.net> [2004-06-30 12:44]:
> Michael W Thelen <thelenm@cs.utah.edu> writes:
> > Log:
> > Handle the log message when requested with an implicit BASE:1 in the working
> > copy, with an empty repository (no revisions). This addresses issue
> > #692... this is not the "saner fix" mentioned by Greg Hudson, just a
> > quick fix for right now since "svn log" in a working copy with an empty
> > repository errors out unnecessarily.
>
> Thanks for the patch, but I wonder -- is it worth it?
>
> That is, if there is a saner fix available, and the bug is so rare and
> so inconsequential anyway (which I believe this one is), then there's
> little point putting in a "quick fix". It would be better to do
> nothing, or do the sane fix.

Well, I don't see a reason not to apply it if it works... but I think my
pedantic nature and current lack of SVN development experience make me a
good volunteer to implement the saner fix. (I want to see the bug
completely fixed, and since it's a harmless bug I probably won't break
anything in trying.) I'll see what I can do.

-- Mike

-- 
Michael W. Thelen
When everybody actually is out to get you, paranoia is just good thinking.
                -- Woody Allen

Received on Wed Jun 30 21:17:58 2004

This is an archived mail posted to the Subversion Dev mailing list.