[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: prompting providers

From: SteveKing <steveking_at_gmx.ch>
Date: 2003-04-01 21:10:46 CEST

> Gack. Steve, this is a very, very hard to read :-). Ben and I just
> spent a long time scrutinizing it, trying to parse out its meaning.

Sorry. I'll try better next time.

> As for the suggestions themselves, they seem quite good (if we are
> understanding them correctly!). It sounds like:
>
> 1) You want to be able to retrieve more than one piece of
> information in a single call to a prompt function. Instead of
> taking a string and returning a string, it should take a list of
> N strings and return a list of N strings. We anticipated that
> this would be needed someday for GUI clients, and you're the
> first person to need it. Can you file an enhancement request?
Yes, you got it right. But for the username/pw provider I suggest
a prompt function which takes two strings, returns two strings and
a boolean. The boolean would indicate if the information should
be stored or not (SVN_CONFIG_OPTION_STORE_PASSWORD).

> 2) You want a prompting function that returns a boolean rather than
> a string. Sounds totally reasonable. Furthemore, you want the
> cert provider to use this new prompter. Sounds great.
Yes, exactly. Maybe instead of a boolean an enum type could also
be used, e.g. for YES/NO/CANCEL/YESTOALL, ...

> Are we understanding correctly?
Yes! And even my mail was such a mess :)

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Apr 1 21:13:08 2003

This is an archived mail posted to the Subversion Dev mailing list.