[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 4916

From: Daniel Rall <dlr_at_finemaltcoding.com>
Date: 2003-02-19 17:54:29 CET

Philip Martin <philip@codematters.co.uk> writes:

> Daniel Rall <dlr@finemaltcoding.com> writes:
>
> > Karl Fogel <kfogel@newton.ch.collab.net> writes:
> >
> > > mark benedetto king <mbk@boredom.org> writes:
> > > > Tweaking. Actually, can't tweak:
> > > >
> > > > $ svn propedit svn:log --revprop -r 4916
> > > > <do some tweaking, then exit the editor>
> > > > subversion/libsvn_ra_dav/util.c:81: (apr_err=175002)
> > > > svn: RA layer request failed
> > > > svn: applying property change to /repos/svn/!svn/bln/4916: 400 Bad Request
> > > >
> > > > Any idea why?
> > >
> > > Hmmm. This is ringing a bell, but I can't remember where we've seen
> > > this before. Anyone recognize it? It looks like it's getting this
> > > error in the server's error_log:
> > >
> > > [Mon Feb 17 23:33:35 2003] [error] [client 65.42.80.147] \
> > > An undefined namespace prefix was used.
> >
> > Huh. I'm guessing that this error message is the result of a XML
> > problem, where the prefix alias "X:" was used without being defined by
> > the enclosing XML snippet. An ethereal trace would be most useful for
> > confirming.
>
> The log message contains "<" and ">" characters -- these characters
> don't work with "propset --revprop" over ra_dav.

Ah, that could certainly screw up the XML parser if the ra_dav
libraries don't XML entity encode the log message.

-- 
Daniel Rall <dlr@finemaltcoding.com>
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Feb 19 17:55:13 2003

This is an archived mail posted to the Subversion Dev mailing list.