[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] cancellation, take one

From: Greg Hudson <ghudson_at_MIT.EDU>
Date: 2003-02-18 04:09:08 CET

On Mon, 2003-02-17 at 21:56, Garrett Rooney wrote:
> i don't have any real problem with moving the code in there, other than
> it being kind of odd to have something associated with 'cancelation' in
> the svn_delta namespace. it just seems more natural for it to be
> called svn_cancel_get_cancellation_editor than
> svn_delta_get_cancellation_editor.

Although we must rigidly adhere to the svn_* prefix on our symbols in
general, libsvn_delta does not deal exclusively with symbols named
svn_delta_*. Observe that most of the symbols in svn_delta.h actually
have the prefix svn_txdelta.

On the other hand, the XML editor was named svn_delta_get_xml_editor()
when we had it, and the name svn_cancel_get_cancellation_editor() seems
dreadfully redundant, so I would favor
svn_delta_get_cancellation_editor() anyway.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Feb 18 04:09:52 2003

This is an archived mail posted to the Subversion Dev mailing list.