[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Problem compiling r909

From: Greg Stein <gstein_at_lyra.org>
Date: 2002-01-31 02:27:20 CET

On Wed, Jan 30, 2002 at 04:28:35PM -0800, Jack Huang wrote:
> Hi there,
>
> I am trying to compile svn source code downloaded by the bootstrap, and am
> running into some problem. I am not quite sure where in the make process
> this occures, but it seems that it happens right after compiling
> db-4.0.14/dist. Here's the error message:
>
> /usr/i486-suse-linux/bin/ld: cannot find -lapr
>
> I assume apr is a library that I do not have. Can you tell me where I can
> get it (gnu.org?) I am running SuSE Linux 7.3, and I did not have this
> problem when I was running Red Hat 7.2.

When you say "downloaded by the bootstrap", you mean checked out from
svn.collab.net? To clarify: that is a lot more recent than rev 909 :-)

That said: you are most liking missing an installation of APR. Please review
the INSTALL document for the necessary build requirements and procedures.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:37:01 2006

This is an archived mail posted to the Subversion Dev mailing list.