[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: db 3.3.11 and Win98 - still problematic

From: <cmpilato_at_collab.net>
Date: 2001-08-13 16:58:24 CEST

Mats Nilsson <mats.nilsson@xware.se> writes:

> I've just verified that Berkeley db-3.3.11 still doesn't solve the problem
> reported earlier for db-3.2.x on Win98. 'svnadmin create' still creates a
> corrupt db environment.
>
> However, running the same binaries on W2k succeeds.

Hey, Mats. Thanks for reminding me that I was supposed to send this
same report out last week *blush*. Indeed, the problem is still not
solved.

CALL TO LIST-FOLK:

We desperately need someone to create a small well-written program
that exhibits this problem on Win9x -- something that mimics the
way we use Berkeley DB in libsvn_fs (with DB_ENV stuff and all those
goodies).

This program should be as small as possible, and beautifully commented
-- in other words, I'd like to be able to send this little program in
a mail to Berkeley DB's support folk so that *they* can reproduce the
problem. I've sent mail to them in the past about the bug, but there
was no way they were going to dive into a codebase of our size to find
this bug.

The results of this operation will be, I hope, either a bug fix from
Sleepycat, or someone there saying, "Well, duh, of course it doesn't
work -- you (did/didn't do) _______________!"

Any takers?

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:36:35 2006

This is an archived mail posted to the Subversion Dev mailing list.