Re: CVS update: subversion/subversion/include svn_delta.h
> > I'd highly recommend using a typedef such as svn_vernum_t to represent this.
> > That gives you one good feature (semantics, leading to readability, type
> > checking, maintenance, understandability) and one minor feature (ability to
> > change the type if necessary; e.g. make it unsigned).
> That seems like a good idea.
> We had a recent phone conversation with JimB where we tentatively
> decided not to make special types that just mirror native C types, but
> I think the reasons for that decision don't apply so well in this
> case. Plus, it's always easier to change back from custom type to
> native type, than the other direction. :-)
Hmm. I don't remember this phone call. Giving meaningful names to
appropriate integer subtypes is a fine thing --- off_t, size_t, time_t
is a fine thing in my book.
Received on Sat Oct 21 14:36:07 2006
This is an archived mail posted to the Subversion Dev